Build:
  1. 2
  2. 1
  3. 0
2022-08-04 12:31.39: New job: Build using linux-ppc64 in
                                []
2022-08-04 12:31.39: Will push staging image to ocurrent/opam-staging:debian-11-ocaml-5.0-no-flat-float-array-ppc64le

Dockerfile:

# syntax=docker/dockerfile:1.4
FROM ocurrent/opam-staging@sha256:5d5d3344605bfe7d793b2ae9e24e190dcae4063d3c092905ecf3f595040a9a29
RUN opam repo add beta git+https://github.com/ocaml/ocaml-beta-repository --set-default
ENV OPAMYES="1" OPAMCONFIRMLEVEL="unsafe-yes" OPAMERRLOGLEN="0" OPAMPRECISETRACKING="1"
RUN opam switch create 5.0 --packages=ocaml-variants.5.0.0+trunk,ocaml-options-only-no-flat-float-array
RUN opam pin add -k version ocaml-variants 5.0.0+trunk
RUN opam install -y opam-depext
ENTRYPOINT [ "opam", "exec", "--" ]
CMD bash
COPY --link [ "Dockerfile", "/Dockerfile.ocaml" ]

2022-08-04 12:31.39: Using cache hint "5.0.0+no-flat-float-array-ppc64le-ocurrent/opam-staging@sha256:5d5d3344605bfe7d793b2ae9e24e190dcae4063d3c092905ecf3f595040a9a29"
2022-08-04 12:31.39: Waiting for resource in pool OCluster
2022-08-04 12:31.39: Waiting for worker...
2022-08-04 12:31.39: Got resource from pool OCluster
Building on oya.ocamllabs.io
#2 [internal] load .dockerignore
#2 sha256:ed87b356c005497ae028d4d75175bda79e6c0550b37d13fba3deebdafab78295
#2 transferring context: 2B 0.0s done
#2 DONE 0.0s

#1 [internal] load build definition from Dockerfile
#1 sha256:fa9bddec97fe914a8cedc55d243460de27b4392c6ab307d7dca2752dadf8aa15
#1 transferring dockerfile: 630B 0.0s done
#1 DONE 0.1s

#3 resolve image config for docker.io/docker/dockerfile:1.4
#3 sha256:21e2ad6211f4d9ab2dd5aebc9b09edc1198fd093d9b235663c88a501ac5205d2
#3 DONE 0.9s

#4 docker-image://docker.io/docker/dockerfile:1.4@sha256:443aab4ca21183e069e7d8b2dc68006594f40bddf1b15bbd83f5137bd93e80e2
#4 sha256:2b0b752d90ca4cde8af1af88f3eb8a267a6a9c8c29baed308724c3c669af429e
#4 CACHED

#6 [internal] load .dockerignore
#6 sha256:6ddc1e9bbb47ddab651691b6836104bbe09621dd09638b30993b723f7c47bc69
#6 DONE 0.0s

#5 [internal] load build definition from Dockerfile
#5 sha256:2d7b8452f7442588f240d65d89562c6706f9e5d919eedbb65e5140c886e68545
#5 DONE 0.0s

#7 [internal] load metadata for docker.io/ocurrent/opam-staging@sha256:5d5d3344605bfe7d793b2ae9e24e190dcae4063d3c092905ecf3f595040a9a29
#7 sha256:17aa87ac31c9ee3b74be464838ab8d8a514956e0e5f9650a08632e56dab2c581
#7 DONE 0.7s

#8 [1/6] FROM docker.io/ocurrent/opam-staging@sha256:5d5d3344605bfe7d793b2ae9e24e190dcae4063d3c092905ecf3f595040a9a29
#8 sha256:90fb8dba524ae4e12cbfee6891d8fcdf172e9d00d81a598fda8c84d8c8f59ea9
#8 DONE 0.0s

#9 [2/6] RUN opam repo add beta git+https://github.com/ocaml/ocaml-beta-repository --set-default
#9 sha256:9cc84cc955bb9f8b4e53efedcdcbf0e20940f510caa2ce915b53bddca3b78d1a
#9 CACHED

#13 [internal] load build context
#13 sha256:be37b7f0fb09379c4c21257549b689f2832b367b4d3937333f300d8aa7f244f2
#13 transferring context: 630B done
#13 DONE 0.0s

#10 [3/6] RUN opam switch create 5.0 --packages=ocaml-variants.5.0.0+trunk,ocaml-options-only-no-flat-float-array
#10 sha256:b6314789cce085451e70f5e5bf6d62b6ea3b02ca09b973851ee6164379b718fb
#10 11.15 Switch initialisation failed: clean up? ('n' will leave the switch partially installed) [Y/n] y
#10 11.15 [ERROR] Could not resolve set of base packages:
#10 11.15         The following dependencies couldn't be met:
#10 11.15           - ocaml-variants -> ocaml-option-bytecode-only
#10 11.15         Your request can't be satisfied:
#10 11.15           - ocaml-options-only-no-flat-float-array is in conflict with ocaml-option-bytecode-only
#10 11.15 
#10 11.15 
#10 ERROR: executor failed running [/bin/sh -c opam switch create 5.0 --packages=ocaml-variants.5.0.0+trunk,ocaml-options-only-no-flat-float-array]: exit code: 20
------
 > [3/6] RUN opam switch create 5.0 --packages=ocaml-variants.5.0.0+trunk,ocaml-options-only-no-flat-float-array:
------
executor failed running [/bin/sh -c opam switch create 5.0 --packages=ocaml-variants.5.0.0+trunk,ocaml-options-only-no-flat-float-array]: exit code: 20
docker-build failed with exit-code 1
2022-08-04 12:31.53: Job failed: Failed: Build failed